ShoutBox
Welcome Guest, login to shout.
ShoutBox Rules, Read Before Posting.
[04-24, 8:20 PM] Do0dles
: anyone have vote cool down script?
[04-15, 5:30 PM] Chris
: @Benethus Please be sure to read the Shoutbox Rules.
[04-14, 11:50 PM] Benethus
: Anyone had the issue that webstore sends duplicate amount of item ingame while using RA?
[04-11, 2:31 PM] Chris
: Hi Billy.
[04-11, 2:12 PM] Billy
: Hello? Lookin forward for any staff member.
[04-07, 1:10 AM] Chris
: If you're unsure of how to download Escalation, you'll just need to go to the UCP and click on 'Download Licenses' to view all of the ones you have licensed to you.
[04-07, 1:09 AM] Chris
: Hey Orion, I checked the ACP. It appears you did manage to purchase Escalation at 8:43PM PDT.
[04-06, 8:48 PM] Orion
: I WOuld Like to Buy The Escalation Theme and Customize it a little bit for my Server but i have pay my cretid and i can't buy it..
[03-27, 4:27 AM] System
: The ShoutBox has been truncated.

Join Date: Jul 10, 2017
Location:
Posts: 3
Debian 9 "Stretch" and Azer-CMS
Posted 09-28-17, at 1:55 AM.

Please Register or Login to remove ads.

Dear all,

Azer-CMS 3 seems not to be compatible with Debian 9 "Stretch". Debian 9 just uses PHP7 (and with a trick PHP5.6*), but Azer-CMS 3 needs PHP5.4 / PHP5.5.


* Trick:
apt-get install apt-transport-https lsb-release ca-certificates
wget -O /etc/apt/trusted.gpg.d/php.gpg packages.sury.org/php/apt.gpg
echo "deb packages.sury.org/php/ $(lsb_release -sc) main" > /etc/apt/sources.list.d/php.list
apt-get update


Is there any plan when Azer-CMS 3 is compatible with at least PHP5.6? (And for PHP7?) Answers like "Azer-CMS 4 would be compatible" is not a valid answer for me since ETA to release is unknown.

Thank you.

---
Best regards
Nitair
Join Date: Sep 10, 2012
Location: Azer CMS
Posts: 632
Debian 9 "Stretch" and Azer-CMS
Posted 09-28-17, at 1:30 PM.
Azer CMS v3.x can run with PHP 5.6.x, but with some issues. Mainly regarding E-Mails, but there were a couple of other things that I just can't remember.

Azer CMS v3.x will most likely never be rewritten officially to be compatible with PHP 7.x, as the point of v4.x will primarily be PHP 7.x compatibility. You can either choose to rewrite portions of v3.x yourself to make it compatible with PHP 7.x, or wait for v4.x.
Join Date: Jul 10, 2017
Location:
Posts: 3
Debian 9 "Stretch" and Azer-CMS
Posted 10-05-17, at 4:57 AM.
Posted By Chris, 09-28-17 at 1:30 PM.
Azer CMS v3.x can run with PHP 5.6.x, but with some issues. Mainly regarding E-Mails, but there were a couple of other things that I just can't remember.

Azer CMS v3.x will most likely never be rewritten officially to be compatible with PHP 7.x, as the point of v4.x will primarily be PHP 7.x compatibility. You can either choose to rewrite portions of v3.x yourself to make it compatible with PHP 7.x, or wait for v4.x.


Thanks for your reply. Then I will rewrite these part in PHP7.

Have a nice day.
Join Date: Jul 10, 2017
Location:
Posts: 3
Debian 9 "Stretch" and Azer-CMS
Posted 10-13-17, at 2:01 PM.
I got it working probably (with PHP 7.X). If you have a closing function, please close it. Thanks again.

^ Advertise Here.