ShoutBox
Welcome Guest, login to shout.
ShoutBox Rules, Read Before Posting.
[05-18, 9:03 PM] Chris
: See here.
[05-18, 8:55 AM] Tias
: any tutorials on how to setting the website up
[05-05, 11:21 PM] Chris
: That's not a bug, that's how it was intended to function originally. For a temporary fix until it's updated for modern standards, you can make a new BBCode.
[05-04, 7:08 AM] Thewizad
: Guys, how can i fix the changelog bug?
When i created/edited the changelog as i want, it displays as a giant block/sentence and i don't want it like this, please help <3
[05-02, 3:23 PM] Chris
: All unactivated accounts that are older than five days have been removed. Please activate your account as soon as possible to avoid this happening.
[04-24, 8:20 PM] Do0dles
: anyone have vote cool down script?
[04-15, 5:30 PM] Chris
: @Benethus Please be sure to read the Shoutbox Rules.
[04-14, 11:50 PM] Benethus
: Anyone had the issue that webstore sends duplicate amount of item ingame while using RA?
[04-11, 2:31 PM] Chris
: Hi Billy.
[04-11, 2:12 PM] Billy
: Hello? Lookin forward for any staff member.
[04-07, 1:10 AM] Chris
: If you're unsure of how to download Escalation, you'll just need to go to the UCP and click on 'Download Licenses' to view all of the ones you have licensed to you.
[04-07, 1:09 AM] Chris
: Hey Orion, I checked the ACP. It appears you did manage to purchase Escalation at 8:43PM PDT.
[04-06, 8:48 PM] Orion
: I WOuld Like to Buy The Escalation Theme and Customize it a little bit for my Server but i have pay my cretid and i can't buy it..
[03-27, 4:27 AM] System
: The ShoutBox has been truncated.

Join Date: Jul 19, 2016
Location:
Posts: 27
Item Store - Failed Purchase
Posted 07-20-16, at 6:47 AM.

Please Register or Login to remove ads.

Your recent purchase via the Item Store could not be processed, because the selected realm is offline.
Your purchase will be flagged and reviewed by an administrator.

Error ID: FRO1-12

Realm is online..

WoWIsrael - Online

Alliance: 1

Horde: 2

Total Online: 3

what should i do? thanks!
Join Date: Sep 10, 2012
Location: Azer CMS
Posts: 637
Item Store - Failed Purchase
Posted 07-20-16, at 11:57 AM.
I need the following information:

  • Have you forwarded your ports?

  • You are using SOAP instead of RA, correct?

  • Are you hosting the CMS on an external machine (basically, on a different machine than the server itself)?

  • If the answer to the first two is 'yes', and a 'no' to the third one, please post your config with all sensitive information either censored or removed.


If you are hosting the CMS on a different machine than the server, the CMS is designed to run on the same machine as the server itself. You will have to modify the CMS to accommodate using an external machine.
Join Date: Jul 19, 2016
Location:
Posts: 27
Item Store - Failed Purchase
Posted 07-20-16, at 1:08 PM.
Posted By Chris, 07-20-16 at 11:57 AM.
I need the following information:

  • Have you forwarded your ports?

  • You are using SOAP instead of RA, correct?

  • Are you hosting the CMS on an external machine (basically, on a different machine than the server itself)?

  • If the answer to the first two is 'yes', and a 'no' to the third one, please post your config with all sensitive information either censored or removed.


If you are hosting the CMS on a different machine than the server, the CMS is designed to run on the same machine as the server itself. You will have to modify the CMS to accommodate using an external machine.

- Yes i did.
-Yep
-Nope I'm using WAMP

my config:
<?php
if(!defined('ACMS')){ header("Location: ../../"); }

//- Site Settings
$debug = 0; #- Debug Mode Enabled? (0 = No | 1 = Yes)

//- Database Connection Info
$port_host = "127.0.0.1"; #- Domain without or IP Address
$db_host = "127.0.0.1"; #- Database Host
$db_user = "root"; #- Database User
$db_pass = "x"; #- Database Pass
$db_data = "cms"; #- Database DB
$db_acc = "auth"; #- Account Database

//- Paypal Settings |:| Do Not Edit
$palurl = array(
"1" => "www.paypal.com",
"2" => "www.sandbox.paypal.com",
);

$palcur = array(
"1" => "USD",
"2" => "EURO",
"3" => "ILS", // Other Currency - cms.paypal.com/us/cgi-bin/?cmd=_render-content&content_ID=developer/e_howto_api_nvp_currency_codes
);

//- Paypal Manual Edit For Security
$palmail = "x";
$palurl = $palurl[1]; // 1 = Paypal, 2 = SandBox
$palcur = $palcur[1]; // 1 = USD, 2 = EURO, 3 = Other

//- RA/Telnet Settings - Manual Edit
$ra_host = "127.0.0.1"; #- World Server Host
$ra_user = "x"; #- Account Username (Access = 4)
$ra_pass = "x"; #- Account Password (Access = 4)
?>


Thanks!
Join Date: Jul 19, 2016
Location:
Posts: 27
Item Store - Failed Purchase
Posted 07-20-16, at 1:24 PM.
ok i manage to fix that, now the problem is that I'm not getting mails in game..
Join Date: Sep 10, 2012
Location: Azer CMS
Posts: 637
Item Store - Failed Purchase
Posted 07-20-16, at 1:39 PM.
What version of PHP is in your WAMP install? (just making sure you have a compatible version)
Join Date: Jul 19, 2016
Location:
Posts: 27
Item Store - Failed Purchase
Posted 07-20-16, at 1:49 PM.
Posted By Chris, 07-20-16 at 1:39 PM.
What version of PHP is in your WAMP install? (just making sure you have a compatible version)

the last one.. i tried to connect Telnet 127.0.0.1 3443 - and its asking for user and password and when i put the RA user and pass its not working..
umm the wamp is the latest one.. php ver 5.6.19
Join Date: Sep 10, 2012
Location: Azer CMS
Posts: 637
Item Store - Failed Purchase
Posted 07-20-16, at 1:52 PM.
You need to use the port for SOAP, not RA. (7878)

We rely on SOAP, not RA. I asked before if you were using SOAP.
Join Date: Jul 19, 2016
Location:
Posts: 27
Item Store - Failed Purchase
Posted 07-20-16, at 1:55 PM.
Posted By Chris, 07-20-16 at 1:52 PM.
You need to use the port for SOAP, not RA. (7878)

We rely on SOAP, not RA. I asked before if you were using SOAP.

i tried to use soap, its not working with TrinityCore new version.. at all..
after i put the older 3.0 before the hotfix it worked...

when i try to reach the soap
127.0.0.1:7878 I'm getting this:

<?xml version="1.0" encoding="UTF-8"?>

-<SOAP-ENV:Fault xmlns:ns1="urn:TC" xmlns:xsd="www.w3.org/1999/XMLSchema" xmlns:xsi="www.w3.org/1999/XMLSchema-instance" xmlns:SOAP-ENC="schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="schemas.xmlsoap.org/soap/envelope/">

<faultcode>SOAP-ENV:Client</faultcode>

<faultstring>HTTP GET method not implemented</faultstring>

</SOAP-ENV:Fault>
Join Date: Sep 10, 2012
Location: Azer CMS
Posts: 637
Item Store - Failed Purchase
Posted 07-20-16, at 2:21 PM.
What revision is your server?
Join Date: Jul 19, 2016
Location:
Posts: 27
Item Store - Failed Purchase
Posted 07-20-16, at 2:39 PM.
Posted By Chris, 07-20-16 at 2:21 PM.
What revision is your server?


TrinityCore rev. 1a2bd0dc3aaa+ 2016-07-15 15:33:23 +0200 (3.3.5 branch) (Win64, Release, Static)
Join Date: Jul 19, 2016
Location:
Posts: 27
Item Store - Failed Purchase
Posted 07-20-16, at 4:33 PM.
OK I manage to fix it all! just 1 little problem with you command:
".send items $char "{$subject}" "{$text}" {$cart} n"
its not the commands, the command is:
send item charname "subject" "text" itemid

when i try to change it to the currect command it shows me a blank page..
Join Date: Sep 10, 2012
Location: Azer CMS
Posts: 637
Item Store - Failed Purchase
Posted 07-20-16, at 5:02 PM.
Try to enable debug mode. I'm sorry, I was busy setting up a test environment to see if the protocol was really the issue. I've been distracted a bit and had some slight delays, so that's why I'm just now compiling PHP in the VM I am using to do this test.

After you enable debug mode, try again to see if you get an error that you can paste to me.
Join Date: Jul 19, 2016
Location:
Posts: 27
Item Store - Failed Purchase
Posted 07-21-16, at 6:22 AM.
OK I manage to fix it all! just 1 little problem with you command:
".send items $char "{$subject}" "{$text}" {$cart} n"
its not the commands, the command is:
send item charname "subject" "text" itemid

when i try to change it to the currect command it shows me a blank page..
Join Date: Jul 19, 2016
Location:
Posts: 27
Item Store - Failed Purchase
Posted 07-21-16, at 6:23 AM.
Posted By Chris, 07-20-16 at 5:02 PM.
Try to enable debug mode. I'm sorry, I was busy setting up a test environment to see if the protocol was really the issue. I've been distracted a bit and had some slight delays, so that's why I'm just now compiling PHP in the VM I am using to do this test.

After you enable debug mode, try again to see if you get an error that you can paste to me.

ok its all fine now using RA (Soap not working on trinity) but I'm not getting the mail..
$telnet = fsockopen($ra_host, $rpt, $error, $error_str, 3);
if($telnet)
{

sleep(5);
fputs($telnet, ''.$ra_user."n");
sleep(5);
fputs($telnet, ''.$ra_pass."n");
sleep(3);

$subject = "Item Store Purchase";
$text = "Thank You, for your purchase.";

$sql_char = $db->query("SELECT guid, name FROM $cdb.characters WHERE guid='$d2'");
$chars = $db->get($sql_char);
$char = $chars['name'];

//Send Items
foreach($sit as $cart)
{
fputs($telnet, ".send items $char "{$subject}" "{$text}" {$cart} n");
Join Date: Jul 19, 2016
Location:
Posts: 27
Item Store - Failed Purchase
Posted 07-21-16, at 6:46 AM.
i don't see that it trying to login in the logs...
i mean i don't see error at all..

^ Advertise Here.